Se puede usar WordPress con PostgreSQL?

WordPress por defecto no tiene soporte para PostgreSQL. Por la misma razón que no tiene soporte para Sqlite u otros, fué diseñado para ser usado con MySQL, los detalles pueden ser vistos aca para los interesados.

No se recomienda usar un port de WordPress a PostgreSQL ya que es dificil manejar los cambios y las mejoras en seguridad. Es por esto que la opcion por ahora es usar un plugin. Si, un plugin, asi de facil!

La ventaja del plugin es que es independiente del core de WordPress, asi que se puede actualizar los otros plugin y la base de WordPress sin problema. Para esto yo use PG4WP

Como se usa? Debe ser en una version nueva de WordPress, se debe descomprimir wordpress en el servidor (o subirlo por ftp) y luego incluir los contenidos del plugin PG4WP en el directorio wp-contents. Luego se debe configurar una base de datos para el blog en PostgreSQL junto con un usuario y contraseña para finalmente instalar wordpress normalmente, pero indicando los datos de conexion a la base de datos PostgreSQL. Eso es todo.

Luego pueden configurar wp e instalar los plugins que necesiten, cambiar el tema, etc. Yo puse los siguientes plugins para comenzar (junto conCarlos Elias):

  1. No comments yet.

  1. No trackbacks yet.